Stream: zulip

Topic: making links to topics pro-tip


view this post on Zulip pnkfelix (Jun 16 2021 at 17:00):

In case others have encountered this issue: I often try to make links to topics, potentially in other streams. E.g. I might want to reference a conversation in #t-compiler > felix chattering . However, in my experience, what often happens is that I start typing #t-compil, the popup comes up with the various streams and a message at the bottom that says “Hit > for topic list.” So I’ll arrow key down to #t-compiler, hit >, and at that point, for some reason, Zulip will pick a different stream, a different one on the list that isn’t #t-compiler but is instead #t-compiler/meetings or similar, and give me a list of topics from within that undesired stream.

view this post on Zulip pnkfelix (Jun 16 2021 at 17:02):

I think what causes the misselection of the stream is that there is a hidden action that I overlook: Typing > in practice (at least on my keyboard) requires first holding down Shift and then striking the . key

view this post on Zulip pnkfelix (Jun 16 2021 at 17:02):

But, if you separate those two acts, you see something very interesting: Hitting Shift itself sometimes (always?) causes the selected stream to change.

view this post on Zulip pnkfelix (Jun 16 2021 at 17:04):

(well, now I cannot replicate the behavior I was observing before. Holding down shift isn’t causing the selection to change. But striking shift, or holding it down and then releasing it, is causing the selection to change: It resets the selected stream to the top of the list…)

view this post on Zulip pnkfelix (Jun 16 2021 at 17:06):

In any case, the most reliable thing I seem to find is to do this: start typing the stream name, via #t-whatev, and then when you see that the list is narrowed enough that you see the stream you want, at that point, hold down shift. Then arrow down to the stream while shift is held, and only once the stream is selected, hit > (i.e. . with shift held down).

view this post on Zulip nikomatsakis (Jun 16 2021 at 19:13):

what I've found works best is:

view this post on Zulip nikomatsakis (Jun 16 2021 at 19:13):

First just write out the stream: #t-compiler and hit enter

view this post on Zulip nikomatsakis (Jun 16 2021 at 19:13):

after hitting enter, hit >

view this post on Zulip nikomatsakis (Jun 16 2021 at 19:13):

#t-compiler > beta noms

view this post on Zulip pnkfelix (Jul 09 2021 at 01:37):

nikomatsakis said:

First just write out the stream: #t-compiler and hit enter

In the app, everything goes wrong for me on this step. Writing out the stream like #t-compiler brings up the prompt, and tries to guess which stream I wanted (which won’t necessarily be #t-compiler), and highlights it. If “just hit enter” there, it picks the highlighted one.

view this post on Zulip pnkfelix (Jul 09 2021 at 01:38):

(Its possible our experience differs because Zulip is making user-dependent choices on how it guesses which stream to highlight. I could easily believe that for niko, #t-compiler gets top billing, while for me, #t-compiler/meeting gets top billing.)

view this post on Zulip nagisa (Jul 09 2021 at 08:40):

So what it does for me is that on > it selects the highlighted topic, no matter what i have written so far. E.g. on #t-compiler if I type > and the popup has #t-compiler/meetings highlit, it will autocomplete to meetings.

view this post on Zulip nagisa (Jul 09 2021 at 08:40):

gotta select the stream you want with arrow keys or whatever.

view this post on Zulip nagisa (Jul 09 2021 at 08:42):

It could put exact matches at the top so you didn't have to fiddle with the arrows and whatnot, but that potentially can be confusing too – e.g. if I mean to select /meetings and type #t-compile, /meetings will always remain the selected option during typing that out for me. If I continue typing r<enter> out of inertia, I'd suddenly get the different result without much visual indication as to why :shrug:


Last updated: Oct 11 2021 at 22:34 UTC