Stream: t-compiler/wg-prioritization/alerts

Topic: #80804 1.49 seems to have bumped required macOS version


triagebot (Jan 08 2021 at 01:55, on Zulip):

@WG-prioritization/alerts issue #80804 has been requested for prioritization.

Procedure

Camelid (Jan 08 2021 at 02:32, on Zulip):

P-high?

Camelid (Jan 08 2021 at 02:32, on Zulip):

We should probably wait to learn more first though.

rylev (Jan 08 2021 at 09:21, on Zulip):

This is a perfect argument for my min_target_api_version RFC

apiraino (Jan 13 2021 at 09:42, on Zulip):

macOS 10.9 is tier 1, so I agree this is high priority.

simulacrum suggests that that missing symbol could be detected by using the weak macro (already doing this job for other unix calls).

triagebot (Jan 13 2021 at 09:42, on Zulip):

Issue #80804's prioritization request has been removed.

apiraino (Jan 13 2021 at 09:53, on Zulip):

by the way, my line of thought for not setting this critical is that 10.9 (mavericks) support ended in 2016, so I'm not sure about the real world impact of this

Hameer Abbasi (Jan 14 2021 at 12:15, on Zulip):

The real-world impact is pretty low, I believe Apple only supports 10.12+.

Last update: Apr 11 2021 at 18:30UTC