Stream: t-compiler/major changes

Topic: Lang Item for Transmutability compiler-team#411

Jack Wrenn (Mar 04 2021 at 19:15, on Zulip):

Aah, sorry. The code snippet at the top reflects everything that needs to live in libcore. Actual impls of BikeshedIntrinsicFrom will be generated on-the-fly by the compiler.

Everything outside of that snippet doesn't need to be in libcore or the compiler.

triagebot (Mar 04 2021 at 19:16, on Zulip):

The associated GitHub issue has been renamed. Renaming this Zulip topic.

Joshua Nelson (Mar 04 2021 at 19:17, on Zulip):

triagebot seems confused, it made a new stream instead of renaming lol

Joshua Nelson (Mar 04 2021 at 19:17, on Zulip):

cc @Camelid , I think you implemented it

Joshua Nelson (Mar 04 2021 at 19:19, on Zulip):

ok I see the relevant bits start at "Solution"

Camelid (Mar 05 2021 at 20:10, on Zulip):

Ah the issue is that it renamed the topic for every message after the rename, not all the messages.

Camelid (Mar 05 2021 at 20:10, on Zulip):

I'll open an issue later.

Camelid (Mar 06 2021 at 04:49, on Zulip):

Camelid said:

I'll open an issue later.


rylev (Mar 25 2021 at 17:15, on Zulip):

@Jack Wrenn just curious what the latest is on the status of this.

Jack Wrenn (Mar 25 2021 at 17:46, on Zulip):

@rylev I think it needs review by the compiler team?

rylev (Mar 25 2021 at 17:47, on Zulip):

I can try to help there.

Wesley Wiser (Mar 25 2021 at 19:12, on Zulip):

From reading the MCP, I have the impression that this is an unstable, experimental implementation to allow us to try out this concept before committing to it in the RFC. Is that correct?

rylev (Mar 26 2021 at 09:22, on Zulip):

@Wesley Wiser that is correct. The reason it was brought up as an MCP is the implementation is unlikely to be trivial and we wanted to make sure the compiler team was onboard before we start introducing some relatively complex machinery. But indeed, this will not be exposed to end users in any kind of stable way. That, of course, will go through the RFC process.

scottmcm (Mar 27 2021 at 22:04, on Zulip):

A thought for the internal version: maybe skip the Assume, and just have a parameter for each of the things? (Just as a way to reduce the scope of the conversation.)

The struct is important for the stabilized thing, so it can be non_exhaustive and have a nicer API, but for the internal thing it would be fine for it to add, remove, or rename parameters as it goes.

triagebot (Mar 29 2021 at 17:36, on Zulip):

@T-compiler: Proposal #411 has been seconded, and will be approved in 10 days if no objections are raised.

triagebot (Apr 08 2021 at 15:04, on Zulip):

This proposal has been accepted: #411.

Last update: May 07 2021 at 07:30UTC