Stream: t-libs

Topic: Std Cursor API for LinkedList

Charles Lew (Jan 10 2020 at 00:46, on Zulip):

I want to help move this forward. What's the best way to do so?

simulacrum (Jan 10 2020 at 02:37, on Zulip):

I suspect the next step here is to prepare an implementation for std (to be landed in an unstable fashion). You can register your interest to do so on the tracking issue --

simulacrum (Jan 10 2020 at 02:38, on Zulip):

to my knowledge there's not been major discussion since the RFC landed so I suspect that implementing it is the next step

Lukas Kalbertodt (Jan 10 2020 at 16:28, on Zulip):

@Charles Lew If you have any questions, just ask here! Do you think you wanna take a stab at implementing this?

Lukas Kalbertodt (Jan 10 2020 at 16:29, on Zulip):

No one wrote down mentoring instructions yet. I could do that. @Charles Lew Would you like mentoring instructions? The other possibility would be to talk about all your questions in chat, which might be more appropriate now. Mentoring instructions are usually useful when we don't have a specific person working on it yet.

Charles Lew (Jan 11 2020 at 11:06, on Zulip):

Thanks! I've put up my PR at

Lukas Kalbertodt (Jan 11 2020 at 11:55, on Zulip):

@Charles Lew Thanks a bunch :) I'm looking forward to this feature

Lukas Kalbertodt (Jan 11 2020 at 11:56, on Zulip):

@Amanieu Regarding the changed method name you suggested: should I create a PR for the rfc repo fixing the RFC text? I can do that if you think it's a good idea.

Amanieu (Jan 11 2020 at 12:25, on Zulip):

@Lukas Kalbertodt Yes that's a good idea.

Lukas Kalbertodt (Jan 11 2020 at 16:23, on Zulip):

@Amanieu I just read the RFC again and am currently renaming. For most of your suggestions everyone agrees, but the story around pop/remove seems less clear. Should I use your remove suggestion anyway and we will discuss this on the tracking issue?

Lukas Kalbertodt (Jan 11 2020 at 16:24, on Zulip):

Furthermore, I would actually name it remove_current. All other operations have an explicit "direction" andcursor.remove_current() seems more readable to me than cursor.remove().

Amanieu (Jan 11 2020 at 18:06, on Zulip):

@Lukas Kalbertodt Sure, remove_current sounds good.

Lukas Kalbertodt (Jan 11 2020 at 18:20, on Zulip):

Lukas Kalbertodt (Jan 14 2020 at 12:46, on Zulip):

I can create a PR expanding the documentation of the cursor API, if you want! I don't mind writing docs ^_^
Or did someone else already plan on doing that?

Amanieu (Jan 14 2020 at 14:05, on Zulip):

Go ahead, I don't think anyone is working on it at the moment.

Last update: Jul 02 2020 at 13:45UTC