Before creating a repository, we need a name for the crate defining the binary event data format.
profile_data? IIUC, this is a more-or-less generic data format
yeah, that would work too
here is a sketch of what the string table implementation could look like, btw: https://gist.github.com/michaelwoerister/85ae5e9bf443a9ee0e5e3f55bbd4c682
Is this an instance where a
rustc_ prefix would be appropriate?
I don't think there'll be anything rustc specific in it and it might be something that get's re-used by salsa in some form.
although something like
profile_data sounds a bit too generic to me
We could do a slightly less literal name
libmetiri for example (metiri is the latin word for measure)
I actually kind of like
libmeasureme, although it was meant more as a joke on the other thread :)
It does seem like a nice name -- though maybe we'd drop the
lib since that's not standard outside rust-lang/rust?
+1 from me :)