Stream: t-compiler/wg-meta

Topic: hugo version


nikomatsakis (Sep 24 2019 at 20:06, on Zulip):

So I am getting errors trying to run hugo. What version do we use?

I have

Hugo Static Site Generator v0.40.1 linux/amd64 BuildDate: 2018-04-25T17:16:11Z

installed

nikomatsakis (Sep 24 2019 at 20:06, on Zulip):

it looks like that is old

nikomatsakis (Sep 24 2019 at 20:06, on Zulip):

I have no idea where that even came from

nikomatsakis (Sep 24 2019 at 20:07, on Zulip):

I guess whatever apt-get gives me in WSL

lqd (Sep 24 2019 at 20:07, on Zulip):

(I have Hugo Static Site Generator v0.56.0/extended darwin/amd64 BuildDate: unknown)

lqd (Sep 24 2019 at 20:08, on Zulip):

and the repo has this 0.56.3

lqd (Sep 24 2019 at 20:11, on Zulip):

and which is even maybe the ubuntu you have in WSL

Santiago Pastorino (Sep 24 2019 at 20:30, on Zulip):

@nikomatsakis let me know if you're able to solve this problem, this is one of the things that I don't like much about our current solution :P

Santiago Pastorino (Sep 24 2019 at 20:30, on Zulip):

unsure anyway how to solve it

nikomatsakis (Sep 24 2019 at 20:43, on Zulip):

I have not figured out how to solve it

nikomatsakis (Sep 24 2019 at 20:44, on Zulip):

I guess I could install hugo by hand or something

davidtwco (Sep 24 2019 at 20:44, on Zulip):

You can just install one of their packages from here: https://github.com/gohugoio/hugo/releases - I think that's what I've done.

nikomatsakis (Sep 25 2019 at 13:06, on Zulip):

Yeah, I was just going to say, I just wget a pre-built binary and things were ok

nikomatsakis (Sep 25 2019 at 13:06, on Zulip):

feels weird but hey it works

Last update: Nov 11 2019 at 21:55UTC