Stream: t-compiler/wg-rls-2.0

Topic: VS Code version


Jonas Schievink (May 17 2020 at 13:35, on Zulip):

What's the reason for bumping the minimum VS Code version so aggressively? It's currently ahead of what even Arch Linux packages, which means that I can't develop on master. AFAICT no rust-analyzer features actually require such a recent version.

matklad (May 17 2020 at 13:51, on Zulip):

"latest stable" is just the simplest possible policy to follow. I think it makes sense to tone it down a bit to at least one release behind.

matklad (May 17 2020 at 13:58, on Zulip):

Fixed in https://github.com/rust-analyzer/rust-analyzer/pull/4496, cc @Jeremy Kolb

Laurențiu Nicola (May 17 2020 at 14:05, on Zulip):

On Arch you can bump the version in the Code PKGBUILD and it compiles fine

Jeremy Kolb (May 17 2020 at 15:09, on Zulip):

Sounds reasonable to me!

Last update: May 29 2020 at 18:00UTC