Stream: t-compiler/wg-rls-2.0

Topic: Error after installing from marketplace


Dhs92 (Mar 13 2020 at 21:41, on Zulip):

[matklad.rust-analyzer]: Proposed API is only available when running out of dev or with the following command line switch: --enable-proposed-api matklad.rust-analyzer

Currently getting this error whenever I open up a Rust workspace using ra from the marketplace with semantic token highlights on

std::Veetaha (Mar 13 2020 at 21:52, on Zulip):

@Dhs you may not use semantic highlighting on stable vscode. You need either to switch to vscode-insiders or turn off this flag:

{
    "rust-analyzer.highlighting.semanticTokens": false
}

Note: I tried running code with --enable-proposed-api matklad.rust-analyzer and it doesn't work on stable vscode, this option doesn't opt in proposed api for some reason (maybe this is a bug)

Dhs92 (Mar 13 2020 at 23:28, on Zulip):

Yes, forgot to include I tried running code with the proposed flag. I'll keep that in mind--thank you!

Last update: Sep 30 2020 at 16:15UTC