Stream: t-compiler/wg-rls-2.0

Topic: issues after updating rust-analyzer in vscode


eryn (Aug 03 2020 at 22:52, on Zulip):

Hello, after rust-analyzer updated today i'm getting a lot of weird issues in vscode and i'm not sure what's causing them. seems like the symbol info is really wrong. sometimes it takes a long time to save too. anyone know what i can do to fix it? image.png

this was just working a few days ago

eryn (Aug 03 2020 at 22:56, on Zulip):

the code compiles and runs fine, but rust-analyzer is doing something really weird in the ide

eryn (Aug 03 2020 at 22:58, on Zulip):

I reverted to extension v0.2.256 and it works fine

eryn (Aug 03 2020 at 22:59, on Zulip):

there's definitely a problem with the update that just went out, 0.2.264

Jonas Schievink (Aug 03 2020 at 22:59, on Zulip):

can you check the output panel? r-a will print panics there

eryn (Aug 03 2020 at 23:01, on Zulip):

i dont see any panics

eryn (Aug 03 2020 at 23:01, on Zulip):

Rust Analyzer Client right?

eryn (Aug 03 2020 at 23:01, on Zulip):

no panics there. the LSP output is reporting a bunch of syntax errors that aren't real

Jonas Schievink (Aug 03 2020 at 23:02, on Zulip):

that's the VS Code plugin, it should be called "Rust Analyzer" I think?

eryn (Aug 03 2020 at 23:02, on Zulip):

image.png

eryn (Aug 03 2020 at 23:02, on Zulip):

image.png

eryn (Aug 03 2020 at 23:03, on Zulip):

in the 1st screenshot it looks like rust-analyzer isn't seeing the real file

Jonas Schievink (Aug 03 2020 at 23:03, on Zulip):

hmm, then you might be hitting the synchronization bugs

Jonas Schievink (Aug 03 2020 at 23:04, on Zulip):

and nothing else

Jonas Schievink (Aug 03 2020 at 23:05, on Zulip):

https://github.com/rust-analyzer/rust-analyzer/issues/5656

eryn (Aug 03 2020 at 23:06, on Zulip):

yeah i guess it's the same issue

Last update: Sep 27 2020 at 13:30UTC