Stream: t-compiler/wg-rls-2.0

Topic: ra_lsp_server crash with invalid type: integer `1`


Rudi Floren (Dec 11 2019 at 16:36, on Zulip):

Hey,
I updated my ra today but now it hit me with ra_lsp_server crashes.
I get this in my vscode extension log for Rust Analyzer Language Server:
Error: Error("invalid type: integer 1, expected string or map", line: 0, column: 0) [Error - 17:26:12] Connection to server got closed. Server will not be restarted.

I wasn't able to find any related github issues. Anyone encountered this?

Running latest rust and rust nightly as well as a clean compile of whole ra_lsp_server

matklad (Dec 11 2019 at 16:39, on Zulip):

@Rudi Floren yep, a known issue due to dependnecy upgrade, I've reverted the dependency upgrade, it'll land in 10 minutes. For know, consider reverting manually to a version several commits back (git reset --hard HEAD~10) should do the trick

Rudi Floren (Dec 11 2019 at 16:40, on Zulip):

Thanks for the quick answer.

matklad (Dec 11 2019 at 16:42, on Zulip):

I just happed to step into this myself a moment ago :)

Jeremy Kolb (Dec 11 2019 at 23:46, on Zulip):

Yep! My bad. That will teach me to push changes on my way to work. Thanks for the quick fix.

Last update: Jan 21 2020 at 08:20UTC