Stream: t-compiler/wg-rls-2.0

Topic: Unable to install extension 'matklad.ra-lsp'


cryo28 (Dec 23 2019 at 02:38, on Zulip):

Sorry for the noob question. Exploring available tooling and trying to install rust-analyzer with VSCode extension. I following install docs and run cargo xtask install. However it seems to be failing at the step that installs compiled extension to VSCode. In particular:

will run: code --install-extension ./ra-lsp-0.0.1.vsix --force
Installing extensions...
(node:273351) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
(node:273351) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
Unable to install extension 'matklad.ra-lsp' as it is not compatible with VS Code '1.40.1576304502'.
Failed Installing Extensions: ./ra-lsp-0.0.1.vsix
Error: install client

Caused by:
    `code --install-extension ./ra-lsp-0.0.1.vsix --force` exited with exit code: 1

What does thi mean and what should I do about it? Thanks.

matklad (Dec 23 2019 at 06:30, on Zulip):

@cryo28 you need to update vscode

Last update: Jan 21 2020 at 08:25UTC