What's the name of the operation that computes the least range containing two given ranges?
extend_to doesn't seem too bad. Might be a little confusing as it implies some sense of "direction", but not sure that's a big deal
If others understand this zulip topic, it should be named to
merge tautologically :)
bounding_range are both good to me.
Let's pick extend_to: it looks better as a method, though, for a free function, bounding_range would be a better choice
If you want to be explicit I think
extend_to_cover would save me from using a hover. An alternative would be a constructor that takes two ranges