hidden intermediate representation!
This is semi-jokingly, but, indeed, that's probably the most important part of our hir_xxx crates -- they are invisible from hir on.
More seriously, I am not too thrilled about our hir terminology, for two reasons:
hir_xxxare very different things, they should have been named differently. They sort-of-were (hir was "code_model"), but not really.
hiris not he same as rustc's one, so we'd better have different names.
I wonder what's the best name for the
hir (top level) thing?
semantic representation ?
hir_ prefix is also not really accurate
I guess it's fairly accurate if you look at it as "hidden"
We already have
ssr , so I will vote for