This might be a good addition to the style guide, assuming it matters, but should unit #[test] functions be prefixed with
test_? Just realized that sometimes they are prefixed and sometimes they aren't
I am undecided on this one
One one hand,
test_ is unneeded, because it duplicates
#[test]. On the other hand, looking for workspace symbols with
test_ is convenient. On the third hand, there really should be a "look only in tests/only not in tests" checkbox for worksacpace search
Is there some ecosystem-wide convention for this?
I don't think there is a convention for this. The book chapter regarding testing doesn't prefix with
test_ which is the only place that comes to mind as some kind of reference point.