Should I rename
Mark" identifies both a macro invocation (
foo!()), and expansion process and expansion result of that macro invocation.
(Depending on the context.)
Mark itself is obviously bad because nobody knows what it is.
On one hand, the invocation is primary and its expansion is secondary, but on another hand "invocation" may mean a
for loop (with "expansion" == "desugaring"), or be entirely invisible in case of e.g. test harness generation.
One naming example:
ExpnInfo is some data attached to the ID in question, it is actively used by various lints, for example.
Would it look better as
InvocInfo? Probably not, since it's usually obtained from a span and span is more associated with an expansion of a macro than with its call.
I think we can afford
Expn looks too similar to