we could rename Kind to Term or Value
downsides: Term may be a bit obscure, and Value is probably more confusing than Kind tbh
we could even flatten them so lifetime parameters and placeholders (assuming NLL handles everything) are just type parameters (but we wouldn't call them "TyParam", just Param) and placeholders
Substs would just be Args I guess?
@Ariel Ben-Yehuda's "small Substs" optimization could even work in more cases, e.g. tuples
Kind seems less confusing than those two IMO
we had this discussion before, didn't we?
there's probably a
C-cleanup issue out there somewhere :P
I don't really know of a "good" term --
Kind feels pretty wrong in the sense that it's only barely a noun to my ears. I mean, it is a noun, but it's not really something I think of as a "thing", more like a category of a thing
but for now I'm sort of inclined to just leaveit
until we come up with a clearly better term (no pun intended)