debug_unreachable! from https://github.com/mbrubeck/rust-debug-unreachable is very different from
debug_assert!... the latter is a NOP in release builds, the former is insta-UB!
Am I the only one who finds that a weird way to name this macro?
there should be an "unsafe" in the name somewhere :slight_smile:
and that too^^
unreachable_unchecked from libstd