Stream: general

Topic: x.py failures with rust-analyzer


RalfJ (May 23 2020 at 10:24, on Zulip):

Since I started using rust-analyzer, I am regularly getting errors like this when calling x.py:

error[E0460]: found possibly newer version of crate `std` which `log` depends on
  --> src/librustc_driver/lib.rs:12:1
   |
12 | extern crate log;
   | ^^^^^^^^^^^^^^^^^
   |
   = note: perhaps that crate needs to be recompiled?
   = note: the following crate versions were found:
           crate `std`: /home/r/src/rust/rustc.2/build/x86_64-unknown-linux-gnu/stage0-sysroot/lib/rustlib/x86_64-unknown-linux-gnu/lib/libstd-85c1f7840b2e949a.rmeta
           crate `log`: /home/r/src/rust/rustc.2/build/x86_64-unknown-linux-gnu/stage0-rustc/x86_64-unknown-linux-gnu/release/deps/liblog-e908fe5e323e7fd9.rlib

error: aborting due to previous error

error: could not compile `rustc_driver`.

Is anyone else having that problem?

Last update: Jun 05 2020 at 21:25UTC